AccuRender nXt

advanced rendering for AutoCAD

I have a few blocks with decals attached that are not rendering with the decals.  I added the decal to the part, made it into the block, and the rendered block does not show the decal.  If I explode the block before rendering the decal does show up.  Any idea what is up with that?  I always had decals in my blocks in AR3 and never had to explode them that I can remember. 

Views: 274

Reply to This

Replies to This Discussion

Like I said, I'm happy to take a look at the model or a simplified model which illustrates some problem with nesting blocks or light sources. So far I really don't have much to go on-- and no known issues.
I included a simplified model in one of my previous posts called render blocks test.dwg.
Thanks-- I missed it. I also, of course, missed the fact that I'm talking to two different users at once-- likely with different problems. Another cup of coffee may be required.
I'll need the decal file as well-- or at least its name-- before I can test.
Never mind-- I found the name internally and was able to reproduce.

Brian-- I'm pretty sure this is a precision problem. For the smaller monitors, the screen is a box with a thickness of 0.005 inches and sits right on another surface. This about 1/10 of a millimeter which may be too small a distance to resolve on your particular model, where the dimensions are on the order of 100 ft or more. This would explain the intermittent nature of the problem, as well as the fact that instancing the screen inside of a block might easily make the precision problem even worse.

I'd recommend drawing the screen as a 3dface rather than a solid-- this will make it easier to apply the decal correctly. I would definitely give it more separation from the underlying solid. The larger monitors use 0.05 inches-- about 1 mm-- which seems to work better.
Hmmm, wont let me reply to your most current reply.

Could be a precision problem, but seems like it is more of an issue for me and the others with inserting multiple instances of the same block. By just deleting the group of monitors on the left the ones on the right start working correctly again. Before I deleted the rest of the model and the other two rooms that had the same monitors the big monitor had the same problem.
nXt instances the blocks after you insert a certain number of copies-- something like 4 or 5-- can't quite remember. Instancing means that I keep only one copy of the geometry just like AutoCAD. This can make precision problems worse. By deleting stuff you may have cut the number of blocks below the instancing threshhold. Precision problems also tend to be very intermittent-- changing the viewpoint or altering the scene geometry can make a big difference.

I did just verify that decals are working generally for instanced blocks. The drawing below has a bunch of blocks-- enough to trigger instancing. Changed the orientation of one of them.

it seems some of my nested blocks were mirrored. changing the X-value to 1.0 instead of -1.0 and rotating as needed took care of it.

thanks
As far as I (currently) know, mirroring should only be a problem WRT some special cases. Decals, of course-- I have my suspicions that displacements will get screwed up as well-- there may be more. There may be something I can do about it-- it's on the list to revisit.

RSS

Search

Translate

Latest Activity

Rich Hart replied to Paul Jackson's discussion Old versions of nXt for AutoCAD
"There is a bug in the logic to find the version with the closest date to your license number that occasionally finds the farm install instead. You should be able to simply download the install the NK21 or the OA30 version from the link I posted…"
21 hours ago
Paul Jackson replied to Paul Jackson's discussion Old versions of nXt for AutoCAD
"Thanks Rich. I also popped-in my license code to the checker, it came up with nXtFarm64_0355.exe Seems to be the render farm though?"
22 hours ago
Rich Hart replied to Paul Jackson's discussion Old versions of nXt for AutoCAD
"This page: http://www.renderplus.com/php/get_all_downloads.php#nXtRender lists all of the versions of nXt for AutoCAD currently available for download. The version from Nov 2014, NK21, will work with your license bought in 2013."
22 hours ago
Paul Jackson posted a discussion

Old versions of nXt for AutoCAD

Is it still possible to download old versions (bought in 2013), of nXt for AutoCAD? Got a new PC, but cannot find my installation file. Thanks.See More
22 hours ago
Roy Hirshkowitz replied to Peter Milner's discussion Reflected background brightness
"Almost certainly.  A fix may be difficult at this point.  The code has not been touched in years."
Aug 21
Peter Milner posted a discussion

Reflected background brightness

In Accurender I can turn up the brightness of the reflected background, but when I send the same render to the farm, it renders as the default brightness.Possibly an oversight or a bug?See More
Aug 21
Alfons Akamp posted a discussion

Accurender für Bricscad

Es gab vor einiger Zeit mal eine Version Accurender nxt für Bricscad.Wird es das in Zukunft wieder geben z.B. für Bricscad 19 oder 20??Wäre super, denn dann könnte ich meine 3D Modelle die ich mit Accurender rendere auch mit Bricscad rendern.See More
Aug 15
Kevin Lockwood replied to Nutan Desai's discussion Old Plants
"Hey, Guess what I found. Plants! There are 3 install EXE files zipped. I assume this comes with all the textures and maps. ar3_plant1.zip ar3_plant2.zip ar3_plant3.zip"
Aug 13

© 2019   Header image courtesy Peter Milner   Powered by

Badges  |  Report an Issue  |  Terms of Service