AccuRender nXt

advanced rendering for AutoCAD

Materials in AutoCAD Architecture 2013 objects not rendering

Just installed AutoCAD Architecture 2013 and then the latest (April 2012) version of nXt but materials set within AutoCAD Architecture objects, like the wood of a door and the glass in windows, do not render correctly, they appear a default grey.  

The Walkabout and AutoCAD shaded views of these objects look correct and this same file in AutoCAD Architecture 2012, with this same latest nXt update, renders fine.

Any ideas how to fix this?  

Also, RPCs don't work now but I assume I need to contact ArchVision to fix that...  

Views: 3062

Reply to This

Replies to This Discussion

For the rpc you need to install the plugin for 2013.

Thanks-- looks like a bug of some sort.  I'll look into it. 

This looks like a major problem-- I need to talk to Autodesk about this one which may take a while.  For now I'd strongly suggest staying with 2012 for ACA.

Thanks, working this out as soon as possible will be VERY much appreciated.  Until then I'll stay with ACA 2012, though the performance increases of ACA 2013 do look attractive...

Yep-- as much of a problem as this is for you, it is a huge headache for me.  I'll do what I can.

Roy, I don't know if this can help you solve this issue, but you might want to know that there was a problem with ACA2013 and its ability to correctly hide lines in elevation drawings (window panes, for instance would not hide the walls behind them).  I finally received a 'hotfix' (which will soon be posted by Autodesk) for this that replaces the AecCore.crx file.  This solved that problem though it didn't affect the problem with nXt...

It may be related, I don't know.  I am actively pursuing this problem via Autodesk.  The technical nature of the problem means that the normal developer support guys can't answer it-- it was referred to engineering about a week ago.  If I don't hear by Friday I'll contact them again and try to expedite it. 

Any update on ACA 2013 using materials??

Nothing substantial.

A little progress here.  There's a workaround that's a little technical but still possible for most people to carry out.  You'll need to be comfortable with the registry editor and have enough permissions to edit an entry in the HKEY_CURRENT_USER hive.  Read on if you're interested.  Otherwise we're not done here-- some folks at Autodesk are still looking at the problem and will report back to me at some point.  I'm also looking for a less technical way to invoke the workaround.  I'll let you know if one exists.

*******

There is a registry item called EnableProgressiveUpdate whose value needs to be changed from 1 to 0 to make it behave like previous versions with respect to nXt.  Use the Registry Editor to search HKEY_CURRENT_USER for it (the Edit->Find... option from the menu).  My search reveals two different locations for the item:

HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R19.0\ACAD-B004:409\AEC\7.0\AecBase70\Preferences

-AND-

HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R19.0\ACAD-B004:409\Profiles\AutoCAD Architecture (US Imperial)\Preferences\AecBase70

In my case, only the second key seemed to make a difference.  Changing the first one had no effect.  Your keys may be slightly different than mine-- for example the :409 code is unique to the US version. 

You'll need to restart AutoCAD to see the effect.

Let me know if you try it.

I did what you have suggested above but did not find
(HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R19.0\ACAD-B004:409\AEC\7.0\AecBase70\Preferences ) in my registry but did find the other.
After one quick test, it is working. I will let you know if anything changes but so far, so good.
Charlie

On another note:  I have been using XI Computers (specializing in cad computers) for many years. I purchase a new one this past month. My existing one was extremely fast but this new one cut the Rendering time down to 8 minutes (25 passes-3840x2880) on my new XI with the existing computer took 25 min. on the same drawing. Saying this just in case someone is interested in a fast machine.

Just heard back from Dev. Support again-- looks like you can type SETENABLEPROGRESSIVEUPDATE at the command line and toggle the thing on and off without regedit.  This is an undocumented command.


RSS

Search

Translate

Latest Activity

Miriam Stern replied to Miriam Stern's discussion Why would my objects render like this?
"oops! sorry!"
4 hours ago
Roy Hirshkowitz replied to Miriam Stern's discussion Why would my objects render like this?
"You sent a PSD file-- I actually need the model to take a look at this.  If it's very big try to send a simpler example showing the problem."
5 hours ago
Miriam Stern replied to Miriam Stern's discussion Why would my objects render like this?
"Thank you!"
5 hours ago
Miriam Stern replied to Miriam Stern's discussion Why would my objects render like this?
"Thank you!  I e-mailed you the file."
5 hours ago
Roy Hirshkowitz replied to Miriam Stern's discussion Why would my objects render like this?
"This is often a coordinate problem (as Akinlolu mentioned) or a units problem.  Type _ddunits at the command line and make sure the insertion units match your actual drawing units.  If you can't figure it out attach the drawing or…"
8 hours ago
akinlolu olugboji replied to Miriam Stern's discussion Why would my objects render like this?
"It is to far from the origin. Move the model such the its centre is at autocad zero(0,0) orgin. This should solve the problem."
yesterday
Miriam Stern replied to Miriam Stern's discussion Why would my objects render like this?
"Mr. Potato head too, which i found on here so It's probably not my modeling... Help!"
yesterday
Miriam Stern replied to Miriam Stern's discussion Why would my objects render like this?
yesterday

© 2015   Header image courtesy Peter Milner   Powered by

Badges  |  Report an Issue  |  Terms of Service