AccuRender nXt

advanced rendering for AutoCAD

This is the first preview of the new nXtRender Batch.

You should only try this if you are adventuresome, and willing to make your way through some undocumented stuff. and not get mad at Rich and I if some things are not working properly.

If you want to try this, you can download it from here:


http://www.mediafire.com/file/em8aq6v0535r8j0/nXtRender_AC_Batch_MB...

And just install it.

This is Beta Test Add-on to nXt and AutoCAD at this point. Later it will be integrated into the nXt install. It should work with most recent versions of nXt. And it should work for AutoCAD 2010-2014 (We haven't tested every possible combination yet)

After downloading, you will get a .ZIP file with a message like this:

Click on the message to install it.

New Ribbon

After installation, a new Ribbon should appear in AutoCAD

Racecar

The Race car loads the nXt sidebar menu (the same as typing in nXt).

Help Button

The ? loads an about box:

(The 'Synch Options' button on the bottom will import some settings made while rendering, but not material changes (yet) from the nXtRender Batch Renderer)

Render Button

The green button will extract your current model and save it to the disk for use with the Batch Rendering process.

After Extract, the Batch Renderer will load as a separate process with this dialog:

You can set the render size, number of passes, etc.

And then start rendering.

I will add more documentation here later, but for now you may need to just try some things out.

Views: 3190

Reply to This

Replies to This Discussion

Running Acad 2013 and WIn XP-64. After installing nXt_Batch_Render and opening a drawing and loading nXt, no nXt_Render_Batch Ribbon is attached to Acad.

If I run the following command at the command prompt, I get the following:

 

Command: NXT_BATCH_RENDER


RPS_AC_RENDER Checking nXtRender for AutoCAD License.
Reading Options.
Set Options.
Start ExtractGeometry.

Rendering Started.

Command:

 

The window quits and I'm back to the Acad editing screen.  No other screen runs.

 

Must I load more .arx files to get the ribbon?

 

 

I'll have Rich look at it when he gets back Monday.

The Batch Renderer is not fully working yet. But it should have worked.

It runs in a separate window, so minimize AutoCAD to make sure it was not running in the background.

The Ribbon should have appeared - but there is something in AutoCAD you have to do to bring up ribbons.

I minimized the Acad  window and no other window existed.  I have all the Acad ribbons showing but, no nXt_Render_Batch Ribbon.   Do I have the latest version (MB08xa) loaded?

Thanks.

Not being as smart as I may-or-may-not-have-been, I noticed the Plug-ins Tab on the small ribbon at the top.  Low and behold, I have a nXt-Render Batch drop-down ribbon.  Sometimes it's tough waking up to smell the posies.

 

If you do try out the Batch Renderer - you are trying it mostly to see if it has any features which we should pursue. It does not render everything properly yet. For example, I don't think it renders RPCs or Plants properly yet.

RSS

Search

Translate

Latest Activity

Roy Hirshkowitz replied to Roy Hirshkowitz's discussion AccuRender Studio
"Here's the png again."
Friday
Roy Hirshkowitz replied to Roy Hirshkowitz's discussion AccuRender Studio
"The png I sent you does have an alpha channel."
Friday
Roy Hirshkowitz replied to Roy Hirshkowitz's discussion AccuRender Studio
"There really isn't much to it.  All I did was go to the Material Editor and replace the bitmaps in the decal with the png version-- I can't remember whether I had to change both the Color and Opacity (I think so.)  If you're…"
Friday
Peter Milner replied to Roy Hirshkowitz's discussion AccuRender Studio
"Okay. I've changed it to a png file. What steps do I take within AR Studio to get it to work properly"
Friday
Roy Hirshkowitz replied to Roy Hirshkowitz's discussion AccuRender Studio
"Use png for this-- it's much more reliable.  All I did was go into the Material Editor and replace your tif with my png."
Friday
Peter Milner replied to Roy Hirshkowitz's discussion AccuRender Studio
"Well, I've tried what you suggested, but I still can't get it to work. I'll send you the model and the decal. Maybe I've got something wrong."
Friday
Peter Milner replied to Roy Hirshkowitz's discussion AccuRender Studio
"I tried closing down AutoCAD, restarting it, opening the drawing, loading nXt and AR Studio and it still didn't show up. However, it did suddenly appear when I started the interactive render."
Friday
Roy Hirshkowitz replied to Roy Hirshkowitz's discussion AccuRender Studio
"If the preview was running you'll need to reload.  Any changes you make to the objects won't be captured automatically. (I need to change the "Go" button color or something when ardecal command is used. If this doesn't…"
Thursday

© 2020   Header image courtesy Peter Milner   Powered by

Badges  |  Report an Issue  |  Terms of Service