AccuRender nXt

advanced rendering for AutoCAD

I've just implemented Intel's denoising library in AccuRender Studio. I think the results are very exciting.  Most models seem to be something like 4-10 times faster(!).  I'm pretty darn sure this makes AccuRender Studio faster than the original Standard Engine, with much better results and much less monkeying around (no daylight sources, reflective shaders, etc.)

The Intel Open Image Denoise, unlike nVidia Optix (which I had previously implemented), does not require a specific GPU.  It runs on modern Intel CPUs and seems to be equally fast and perhaps a little better in quality.

You can get it on the Download->AccuRender Studio page.  Please note that I have changed the names of the AutoCAD plugins, so early adopters will have to repeat the netload command step.

*******

A couple of examples, courtesy of Peter Milner's models.  Click on them to see them full size.

I do have a relatively fast 16 core machine, however, this one ran for one minute(!):

This one ran for five minutes-- it's got a ways to go but this level of completion would have been hours and hours before.

More to come.

Views: 868

Reply to This

Replies to This Discussion

this looks excellent, I've just upgraded to AutoCAD2020, would you be working on an arstudio plugin for 2020 soon? 

I'll check and see if the development tools are out there yet.  If so, I can build one right away and you can test it for me.

It looks like the 2019 version should work.  Give it a try and let me know.  I will change the online instructions to reflect this.  (The 2019 version nXtRender should work as well, I think).

Yes, I have loaded the 2019 version and all seems to be working fine!

Right.

AutoCAD 2020 is Release 23, just like AutoCAD 2019, so you just need to APPLOAD the 23 module for AutoCAD 2020.

It would be useful if you could adjust the amount of denoising as it tends to hide details and textures.

On a different point. When the preview render is paused, as soon as you alter the view, the rendering commences, but the symbol in the top left corner still says it is paused.

It isn't adjustable-- you can turn it off if you want in the Adjust Image tab.  It isn't perfect, it will blur some detail particularly early on, but does tend to resolve really nicely and much faster than the noise would.

I'll check out the pause issue.

When I click on the Open Material button I get the following error:

Then when I click on OK, I get this:

Is anyone else seeing this when clicking on the Open Materials button?

No, it works for me.

Is there a way of straightening the verticals, or does that now have to be done in Photoshop?

There is a 2 point perspective under camera-- if that's what you mean.

RSS

Search

Translate

Latest Activity

Alfons Akamp replied to Alfons Akamp's discussion Flecken in Bilder
"Richtig, darum rendere ich im Standard Modus. Right, that's why I render in standard mode."
19 hours ago
David Richards replied to Alfons Akamp's discussion Flecken in Bilder
"As you point out, it's not practical to render 250-300 frames for an animation in Hybrid Mode.  Packet Mode is  the most efficient way do this with our software."
Tuesday
Alfons Akamp replied to Alfons Akamp's discussion Flecken in Bilder
"Hallo David Das mag alles richtig sein, was Sie sagen. Für Einzelbilder ist es auch kein Problem da mal eben über Nacht 800 oder 1000 oder 1500 Passes zu machen. Aber was ist, wenn man eine Animation mit 250 - 300 Bilder rendert? Wenn…"
Monday
David Richards replied to Alfons Akamp's discussion Flecken in Bilder
"This page on our site provides some insight into the performance of the different engines http://www.renderplus.com/wp2/wk/NXtRender_Rendering_Engines.htm#Hybrid_Engine_4"
Sep 18
Alfons Akamp posted a discussion

Flecken in Bilder

Ich habe da mal eine Frage:Wenn ich Bilder im Standard Modus rendere, sehen diese sehr gut aus.Wenn ich das gleiche Bild im Hybrid Modus rendere, habe ich jede Menge kleine weisse Punkte und Flecken in dem Bild.Warum und wieso kommen diese Flecken????I've got a question:When I render images in standard mode, they look very good.When I render the same image in hybrid mode, I have tons of tiny white spots and spots in the image.Why and why do these spots appear ????See More
Sep 5
Dizzy Gosnell posted photos
Aug 12
George Ioannidis posted discussions
Aug 10
George Ioannidis commented on Peter Milner's photo
Thumbnail

sven-home ambus exec lifestyle 01

"Very professionally looking render! Looks very photo-realistic."
Aug 10

© 2020   Header image courtesy Peter Milner   Powered by

Badges  |  Report an Issue  |  Terms of Service